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Introduction 
The Model 6502 Thunderstorm/Lightning Sensor detects 
electrical discharges associated with thunderstorms within a 200 
nautical mile (nm) radius of the system. The Model 6502 is a 
passive sensor that listens for electromagnetic signals with a 
receiving antenna. There is no transmitter, and so no harmful 
transmissions.  

The entire package (consisting of an antenna mounted to a 28" 
x 32" ground plane, and a processor and interface board housed in 
a NEMA 4X enclosure) mounts simply to a 2½" pipe (2.875" 
O.D.) using two U-bolts.  

The Graphic Display shows detected strikes overlaid onto a 
map of the monitored area. A set of pull-down menus allows the 
user to configure the display and to add labeled locations to the 
map. 

 



Thunderstorm/Lightning Sensor and Graphic Display User's Manual 

Page 2 

Sensor Theory of Operation 
Detection 
The Model 6502's antenna is a combined crossed-loop and sense antenna, which can 
correlate the electric and magnetic signatures of lightning strikes better than other systems 
due to its patented sense channel technology. The antenna has been designed to help filter out 
pulsed noise from sources other than atmospheric electrical discharges. 

The antenna detects the electrical and magnetic fields generated by intra-cloud, inter-
cloud, or cloud-to-ground electrical discharges that occur within a 200 nm radius of the 
antenna, and sends the resulting ‘discharge signals’ to the processor. The processor digitizes, 
analyzes, and converts the discharge signals into range and bearing data, then stores the data 
in memory.  

Processing 
The Model 6502's processor is housed inside the sensor enclosure along with the Interface 
Board. The processor includes data acquisition circuitry and circuitry to process strike data. 
The Interface Board provides a data buffer and handles communication.  

The sensor transmits a data package consisting of strike data and status information every 
five seconds. When errors are detected, the errors are recorded in an error log. 

Reporting 
The Model 6502 detects the presence of a thunderstorm or lightning event within 200 nm 
from the point of installation. 
1. Range and Direction 

Reports thunderstorms/lightning within a 200 nm radius from the installation point. 
2. Resolution 

Location of thunderstorm is ±1nm from actual location of the thunderstorm/ lightning. 
4. False Reports 

   Not more than 2%. 
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Sensor Installation & Checkout 
 
The Thunderstorm/Lightning Sensor package (consisting of an antenna mounted to a 28" x 
32" ground plane and a processor housed in a NEMA 4X enclosure) mounts to a 2½" pipe 
(2.875" O.D.) using two U-bolts. A section of 2.5" (64 mm) I.D. standard galvanized steel 
pipe can be used as a mast with no drawbacks or special adaptation. Refer to the site 
preparation instructions and applicable drawings for foundation, grounding, conduit, and 
junction box installation details. 

 
CAUTION 

The Thunderstorm/Lightning Sensor's ground plane extends well 
beyond the edges of the sensor enclosure. Be aware of this 
hazard when working around the sensor. 

 

RFI/EMI Precautions 
The Model 6502's antenna is sensitive to static charges, so care must be taken to ensure that 
the antenna and ground plane are as far removed as possible from composite materials (e.g., 
plastic materials or fiberglass), since these materials have a tendency to build up static 
charge. 

The sensor should be mounted as far as possible from devices that emit high levels of 
radio frequency interference (RFI) and electromagnetic interference (EMI), such as VHF and 
UHF radios, RF modems, fluorescent lamps, and ballasts, air conditioner and heater blowers, 
as well as any current-carrying cables. General clearance guidelines are: 

• Strobe lamps and power supplies - 5 ft (1.5 m) 
• Fluorescent lamps and ballasts - 5 ft. (1.5 m) 
• Air conditioners and heater blowers - 5 ft. (1.5 m) 
• Telephone antennas - 4 ft. (1.2 m) 
• VHF communication antennas - 1 ft. (0.3 m) 
• Any current-carrying cable - 2 ft. (0.6 m) 
In addition to the above restrictions, certain site installations may have to be scrutinized 

more carefully from an RFI/EMI perspective. Finding locations to mount the ground plane 
and antenna that will minimize interference from RFI/EMI sources can be enhanced by the 
use of standard RFI measuring equipment. The recommended equipment for monitoring the 
proposed installation area is a typical spectrum analyzer with a broadband conical antenna. 
The spectrum analyzer should be set up to scan the frequencies of concern (100-500 MHz) 
for the typical VHF and UHF radio links near the installation. Once it has been determined 
that there is significant interference, it is imperative that the lightning sensor be moved to a 
location as far from the interfering device as possible. Under no circumstances should the 
lightning sensor antenna and ground plane be placed within one foot of either a VHF or 
UHF transmitting antenna. 

Sensor Installation 
After installing the mast, conduit, and junction box, follow the instructions below for 
assembling and installing the sensor. 
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1 If the signal and power cables have not already been installed between the signal and 
power distribution boxes and the sensor pad, pull the required lengths of cable 
through conduit to the junction boxes at the sensor pad. 

2 (See Figure 1). The mounting bracket attaches to the underside of the 6502 enclosure 
with 4 bolts. Position the bracket against the underside of the enclosure so that the 
mounting holes in the bracket and enclosure align.  

3 Apply RTV 162 to the threads of the four 5/16" hex mounting bolts. 
4 Fasten the bracket to the enclosure with the four 5/16" hex bolts, flat washers, and 

lock washers. 
5 Tighten the bolts. 

Ground
Clamp

5/16" bolts (x4)

 
Figure 1.  Bracket installation 

 
6 Set the sensor package (antenna, ground plane, enclosure, and bracket) on the mast, 

and fasten loosely with two U-bolts, lock washers, and flat washers as shown in 
Figure 2. 

 

 

Bracket

U-bolts 

Signal Cable 

Enclosure 

Power Cable

 
Figure 2.  Sensor package mounting 

 
7 Align the antenna to True North. 
8 Tighten the two U-bolts. 
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9 Open the sensor enclosure by loosening the four countersunk bolts shown in Figure 
3. Do not remove the six bolts holding the ground plane to the enclosure lid. 

 

Loosen

Ground plane

Loosen 

 
Figure 3.  Opening the sensor enclosure 

 
10 The sensor enclosure lid is equipped with hinged bolts (see Figure 4) to allow the 

box to be opened with the ground plane attached. Grasp both sides of the ground 
plane and lift straight up as far as possible (about 3"), then tilt the ground plane and 
lid over carefully to gain access to the enclosure interior. When fully open, the 
ground plane will rest against the side of the enclosure. 

 

 
Figure 4.  Enclosure hinges 

 
11 Connect the incoming AC power wires to the AC interface board inside the enclosure 

(Figure 5) according to Table 1. 
12 Close the enclosure lid and tighten the four countersunk bolts. 
13 Fasten a ground wire between the ground cable installed during site preparation and 

the ground clamp on the underside of the enclosure (see Figure 1). 
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Figure 5.  Interface board 

Table 1.  Lightning detector power wiring. 

AC Interface Board TB1  
Pin Function Color 

1 HOT BLACK or BROWN 

2 NEUTRAL WHITE or BLUE 

3 GROUND GREEN 

AC Interface 
Board
TB1

1

2

3

HOT (BLACK or BROWN)

NEUT (WHITE or BLUE)

GND (GREEN)

AC Interface 
Board
TB1

1

2

3

HOT (BLACK or BROWN)

NEUT (WHITE or BLUE)

GND (GREEN)

     220V

     Neutral

     Ground
AC

     110V

     110V

     Ground
AC

Or
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Checkout 
To verify the sensor is working properly, power the sensor up and verify that, after one 
minute of operation, data is reported from the sensor. (Bear in mind that, in the absence of 
lightning in the measuring area, the data screens will report no strikes.)  
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Graphic Display 
Lightning data is viewed on a graphic display that shows detected strikes overlaid onto a map 
of the monitored area (Figure 6). A set of pull-down menus allows the user to configure the 
display and to specify areas of interest for display on the map. 

 

 
Figure 6.  Lightning Graphic Display 

The graphic display provides a strike locator overlaid on a map of the area being 
monitored. The strike locator indicates both distance and direction of strikes using a grid of 
four concentric rings (representing distance ranges from the center point) combined with 
directional octants. The center point of the locator is normally the site of the lightning sensor, 
and is entered by the user through the Lightning tab on the Edit>Configuration menu.  

Each distance ring represents an increased distance from the locator’s center point of 50 
nautical miles: 

• The innermost ring of the locator shows strikes detected within 50 nautical miles 
of the center point.  

• The next ring out shows strikes within 100 nautical miles of the center point. 
• The third ring out shows strikes within 150 nautical miles of the center point. 
• The outermost ring shows strikes within 200 nautical miles of the center point. 
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The directional octants divide the strike locator into eight distinct compass directions, 
making it simple to quickly identify the direction and distance of detected lightning strikes. 

Zooming In and Out 
The zoom icons in the upper right of the display allow you to zoom the map view in and out.  

• Click the  icon to zoom in to view a smaller area of the map. 

• Click the  icon to zoom out for a wider picture. 
 

Map Key 
Once a strike has been detected, it remains visible on the screen for the 

length of time specified in the Decay Time option on the 
Configuration menu (see page 18). In order to provide a graphic view of 
strikes over time, the color of the strike changes as it ages. As the Map 
Key in the lower right corner of the display shows, new strikes are shown 
in red. As they age, they become progressively lighter in color, changing 
to orange, then yellow, until they finally disappear from the map. In the 
example, the decay time has been set to 15 minutes.  

The Scale indicator at the bottom of the key shows the distance scale 
for the currently displayed map. 
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Menus 
File Menu 

 

The File menu contains options for logging in and out, printing, and 
window control. 
 
 
 
 

 

Login 
The Login option is used to log in to the system as a User. Each User has access to 

specific screens and functions, as set by the administrator through the User Authorizations 
and Group Authorizations options on the Edit menu. The use of these options is explained in 
detail in the next section. 

• To log in, select a User from the pull-down menu. 
• Enter your password in the Password field, then click OK. 
• The User name under which you are logged in will be shown in parentheses at the top 

of the screen, and all applicable menu options will now be available. 
 
Use the area below to record your system’s username and password: 

Username __________________________________________ 
Password __________________________________________ 
 

Logout 
To log out of the current group, click Logout. All menu options requiring login will be 

grayed out. 
Print 
The Print option lets you print the current lightning display. When you click Print, the 
standard Windows print screen will be displayed. 
Print Preview 
The Print Preview option lets you see a preview before printing of what the Print command 
will output to the printer. 
Page Setup 

The Page Setup option lets you set printing preferences. Clicking Page Setup will call up 
the standard Windows printing options screen. 
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Minimize 
Click the Minimize option to minimize the display. The software will continue running 

when minimized. To restore the display to full screen, click the AWI MetObserver icon on 
the application toolbar at the bottom of the screen. 
Exit 

Click the Exit option to close the software. After exiting, the software will continue to 
run as normal. 

Edit Menu 

 

The Edit menu contains options for setting up group and user 
authorizations, configuring the display, configuring ports, and 
setting “points of interest”. 

 
Group and User Authorizations 

The display software is highly configurable through a series of user menus. Often, 
though, configuration changes may best be restricted to authorized users. The Group and 
User structure of the software allows permission to be allocated as required to control access 
and maintain the integrity of system operations. Authorization menus are generally only 
available to Administrators, though those permissions can be given to other groups as well. 

• Group Authorizations allow administrative functions to be enabled or disabled, and 
access to the three data views to be assigned.  

• User Authorizations grant group membership to individual users. A user can belong 
to one or more groups. On logging in, the user will be granted access to all the 
functions allowed for each group in which he has membership. 

• Authorization changes take effect immediately on exiting a configuration dialog and 
returning to the main display. 



Thunderstorm/Lightning Sensor and Graphic Display User's Manual 

Page 12 

Group Authorizations 
The Group Authorizations... option allows administrators to set group permissions.  

• To configure group permissions, log on as an authorized user with Admin rights and 
select Edit>Group Authorizations to call up the screen shown in Figure 7. 

 
Figure 7.  Group Authorizations Screen 

The Group Authorizations screen lists all current groups and the authorized features 
available to each. The Authorization Name shows the name of the group, followed by a 
series of checkboxes that shows the functions a group is authorized to access. A function is 
accessible when it is checked. The table below explains each of the functions. 

Function When Checked 
Admin Gives the group administrative privileges, including Group and User 

Authorization 
Config Lets the group change configuration settings (Edit>Configuration) 
Logs Lets the group view and retrieve data logs (Logs menu) 
Lightning View Lets the group select the Lightning view from the View menu 

Adding a Group 
To add a new group, click the New button at the bottom of the screen. The screen shown 

in Figure 8 will be displayed. 

 
Figure 8.  New Group Screen 
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• Enter a name for the group. 
• Select all the features from the Features panel that you want the group to have access 

to. 
• Select all the views from the Views panel that you want the group to have access to. 
• Click Save to add the group. 
• Click Cancel to return to the Group Authorizations screen without adding the group. 

Editing a Group 
To edit a group’s authorizations, highlight a group on the list and click the Edit button at 

the bottom of the screen. The screen shown in Figure 9 will be displayed. 

 
Figure 9.  Edit Group Screen 

• Check or uncheck Features and Views to enable (check) or disable (uncheck) access. 
• Click Save to save the changes. 
• Click Cancel to return to the Group Authorizations screen without saving the 

changes. 
Deleting a Group 

To delete a group, highlight the group name on the Group Authorizations screen and 
click the Delete button at the bottom of the screen. The group will be deleted immediately. 
Note: You cannot delete a group that has a user associated with it. The Administrator group 
cannot be deleted. 
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User Authorizations 
The User Authorizations... option allows authorized users to define new users and 

associate them with the appropriate groups. 
• To configure user permissions, log on as an authorized user with Admin rights and 

select Edit>User Authorizations to call up the screen shown in Figure 10. 

 
Figure 10.  User Authorizations Screen 

The User Authorizations screen lists all current users along the left side and all existing 
groups along the top. The Authorization Name shows the name of the user, followed by a 
checkbox for each available group. A checkmark beneath a group indicates that the user is a 
member of that group with access to all the features associated with the group. 
Adding a User 

To add a new user, click the New button at the bottom of the screen. The screen shown in 
Figure 11 will be displayed. 

 
Figure 11.  New User Screen 

• Enter a name for the user. 
• Enter a password for the user.  
• To confirm the password, re-enter it in the Retype Password field. 
• Select each of the groups in the Groups panel to which the user will belong. 
• Click Save to add the user. 
• Click Cancel to return to the User Authorizations screen without adding the user. 
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Editing a User 
To change a user’s password or change the groups the user belongs to, highlight the 

user’s name on the list and click the Edit button at the bottom of the screen. A screen similar 
to that shown in Figure 12 will be displayed. 

 
Figure 12.  Edit User Screen 

• To change the user’s password, enter a new password in the Password field.  
• To confirm the password, re-enter it in the Retype Password field. 
• Check or uncheck groups in the Groups panel to set the groups to which the user will 

belong. 
• Click Save to save the changes. 
• Click Cancel to return to the User Authorizations screen without saving the changes. 

Deleting a User 
To delete a user, highlight the user’s name on the User Authorizations screen and click 

the Delete button at the bottom of the screen. The user will be deleted immediately. 
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Configuration 
When you select Configuration from the Edit menu, the main configuration screen (Figure 
13) appears. This screen contains a series of tabs that provide access to the various 
configuration functions. 

 
Figure 13.  Configuration Menu – Airport General Tab 

• To access a configuration category, click the appropriate tab at the top of the screen.  

• The Airport and Misc categories also provide secondary tabs that group similar 
options under a common heading.     
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Airport Tab 
The Airport tab (Figure 13) contains two sub-tabs: General and Runways. 

General  
The Airport>General tab contains several options unique to the airport location. 

General  

Airport Name The name entered here will be shown at the top of the display.  

ICAO Identifier The four-letter ICAO airport identifier or three-digit airport identifier. 

Magnetic Declination 

The display map is oriented to True North; this option allows you to enter a 
site’s magnetic declination, so that the strike locator is oriented to Magnetic 
North. When a value is entered here, the strike locator will rotate on the screen 
to a Magnetic North orientation. When entering a magnetic declination, you 
must also specify East or West declination by selecting the East or West button. 

 
Runways 

The Airport>Runway tab (Figure 14) contains a single field for specifying the ID of the 
runway where the lightning sensor is installed. 

 
Figure 14.  Airport Runway Tab 

Runways  

Runway 
Enter the number/designation of the runway associated with the lightning sensor. 
The value can consist of a 2-digit number from 1-36, or up to four text characters. 
When a numeric value is entered, it can be followed by an optional auxiliary 
designator (R or L, for example). 
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Map Tab 
The Map tab (Figure 15) lets you specify the center point of the lightning display and set the 
decay time for strikes. 

 
Figure 15.  Lightning Tab 

• In the Center Point panel, enter the latitude and longitude of the location you 
would like to set as the center of the lightning map.  

• In the Decay Time field, enter the number of minutes for a strike indicator to 
remain on the screen. As the strike ages over this time period, it will change color. 
When the decay time period has elapsed, the strike will be erased. The value 
entered here will be reflected in the map key. 

• When done, click OK. 
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Misc Tab 
The Misc tab lets you specify the number of days to retain logs in the system before 

deleting them, and set the system time. 
General Tab 

In the text box under the General tab (Figure 16), enter the number of days the system 
should maintain log files before overwriting them. The value can be anywhere in the range of 
4 days to 999 days. 

 
Figure 16.  Logs Tab 
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Time Tab 
Use the Time tab (Figure 17) to set the GPS receiver as the time source for the software 

or to manually enter the time and date. Use GPS Time should be selected in normal 
operation; disable only if the GPS Receiver fails or is not installed. 

• Select Use GPS Time to obtain time and date data from the GPS Receiver. 
• To specify the time and date manually, uncheck the Use GPS Time box and enter 

the date and time in the corresponding fields. To change the date, click the calendar 
icon to call up a monthly calendar, then click the appropriate date. To change the 
time, click within each time field and manually enter a value. This option will use 
the computer’s built-in clock, which is less accurate than the GPS Receiver. 

 
Figure 17.  Time Tab 
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Port Configuration 
The Port Configuration option (Figure 18) is used to specify the communication ports used 
by the lightning sensor and GPS. It also provides the option of scanning a range of ports 
periodically. 

• In the Lightning Sensor Port field, enter the number of the port the lightning 
sensor is connected to. Enter only the number; if the sensor is connected to 
COM 1, for instance,  enter “1”. 

• In the Port field of the GPS panel, enter the number of the port the GPS is 
connected to. This is a USB port, so the number is assigned automatically by the 
operating system and will always be at least 1 greater than the number of physical 
ports. To see the assigned port number, follow the steps below with the GPS 
connected: 

o Go to Start>Control Panel>Performance and Maintenance>System, 
select the Hardware tab, then click Device Manager. 

o On the device list, click the + sign beside the Ports (COM & LPT) 
heading to expand it and show the list of serial ports. 

o Note the port number for the GPS. 
• The Scan Ports option initiates a periodic scan of serial ports to detect the GPS if 

its port number has changed. This can happen if the GPS has been plugged into a 
different USB port or if another USB device has been connected. In the Scan 
Start Port field, enter the lowest USB port number (1 greater than the number of 
physical ports). In the Scan End Port, enter the highest port number to scan. The 
maximum is 255. 

• When done, click OK to save the settings.  
 

 
Figure 18.  Port Configuration 
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Points of Interest 
The Points of Interest option (Figure 19) on the Edit menu lets you add reference locations 
to the map on the main display. Once entered, the names of the points of interest will be 
shown on the main display at their specified locations. 

 
Figure 19.  Points of Interest Option 

 
Adding a Point of Interest 
To add a point of interest, click the Add button at the bottom of the Points of Interest dialog. 
The screen shown in Figure 20 will be displayed. 

 
Figure 20.  Add Point of Interest Dialog 

1. Enter the latitude of the desired reference point in degrees, minutes, and seconds 
in the Latitude text boxes. 

2. Enter the longitude of the desired reference point in degrees, minutes, and 
seconds in the Longitude text boxes. 

3. Enter a name for the point of interest in the Name text box. This is the name that 
will appear on the main display. 

4. Click OK to save the point of interest, or click Cancel to exit the dialog without 
saving the point of interest. 
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Editing a Point of Interest 
To edit a point of interest: 

1. On the list of points of interest, highlight the name of the location you want to edit. 
2. Click the Edit button at the bottom of the screen. The Add Item screen (Figure 20) 

will be displayed. 
3. Adjust the latitude, longitude, and name as needed. 
4. Click OK to save the new values, or click Cancel to exit the dialog without saving 

the changes. 

Removing a Point of Interest 
To remove a point of interest, highlight its name on the list and click Remove. The point of 
interest will be deleted. 

Logs Menu 
The Lightning Display software records each strike detected, and stores the complete 

data for one day in a daily strike log. If no lightning is detected, no log will be generated for 
that day. The length of time that log files are maintained is set by the user via the 
Edit>Configuration>Misc>Logs menu option. Log files older than the time set through that 
screen are automatically deleted. 

Viewing Logs 
Clicking Daily on the Logs menu calls up an Open Log screen such as the one shown in 

Figure 21. 

 
Figure 21. Open Log Screen Example 

Log files use the naming format: DLYStrike.yyyymmdd.log, where yyyymmdd 
represents the date the data was recorded. In the example above, for instance, the file 
DLYStrike..20090414.log contains strike data for April 14, 2009.  

1. To open a log file, click the desired file to highlight it, then click Open. 
2. You can view the file on-screen, or select Print to print the data log. When done, 

click OK to close the window. 
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Data Format 
The lightning sensor data format is described below. 

 
Communications is RS232 9600 8N1 
Output data format is : <STX><i d ><ddd><CR>(<id><ddd><CR>) . <cc ><ETX> 

STX:  is the ASCI I Start-of-Text Character (02h ) 
id:  is the item designator from the table below 
ddd :  is the value of the data item in the Item Format column in the table below 
CR:  Carriage Return 
cc :  checksum - summing all data between STX and “.”, then masking all but the 

lower 8 bits. 
ETX:  is the ASCII End-of-Text Character (03h ) 
 

Item 
Designator 

Item Format Field Width 
(bytes) 

Item Description 

%I dmch 4 System Status, where d is "F” = fatal fault ,”R" = recoverable fault, "P" = 
O.K. 
Display Mode m is transmitted as follows: 

“A”  Weather 
“B”  Noise Monitor 
“C”  Strike Test 
“D”  Demo 
“E”  Pilot Initiated Self-Test 

Configuration data c is sent as 010:B4:B3:B2:B1:B0 where 
 Heading_Config  Synchro  Stepper  Serial  None 
B4  HdgFormat1_lnput  1 0 1  0 
B3  HdgFormat2_lnput  0 1 1  0 
B2  Heading Flag Input Sense; 0 if a High level signal on Heading 
Flag+ (pin P2-24) with respect to Heading Flag- (pin P2-25) indicates 
Valid Heading 
B1  Antenna. Mount 0=Bottom, 1=Top 
B0  Spare 

Heading Flag h is sent as 010:B4:B3:B2:BI :B0 where 
B4  Heading Stabilization 1=Enabled 
B3  Heading Flag Input 1=Valid 
B2  Heading Valid 1=Valid 
B1  Synchro Reference Flag 1=Valid 
B0  Synchro Angle Flag 1=Valid 

Heading Stabilization state defaults to last state when powered up. 
Synchro Reference Flag and Synchro Angle Flag will he zero when 
configured for Stepper or Serial heading input. 
Transmitted once per message. 

%S cccbbbrrr 9 ccc=Range to strike ("001" - "200" NM) Cell mode (a value of 201 indicates 
invalid); bbb=Bearing to strike, clockwise in degrees “000” - "359" deg). 
rrr=Range to strike (“001 – “200” NM) Strike mode. This Item Designator 
may appear from 0 to 40 times per message depending on thunderstorm 
activity. Invalid Cell mode range indicates the strike is not displayed in Cell 
mode view. In Noise Monitor Mode, ccc will always indicate 201 and rrr will 
have a range of 001 – 400. 

%A rrrbbb 6 Test strike range and bearing. rrr=Range to strike ("001" - "200" NM); 
bbb=Bearing to strike, degrees clockwise("000" - "359" deg). Transmitted 
once per message block. Only transmitted when in Strike Test Mode. 
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%E dd 2 Fault code (“00” – “99”), more than one possible (%E for each code up to 
5 codes), see table. Transmitted each message only when System 
Status (%I) indicates fault or degraded operation. 

%V Xxxxxx 6 X=”B”, xxxxx=S/W version string, padded on right with "spaces" if needed. 
Transmitted at least 2 times per minute. 

%T ddddd 5 ddddd=”00000” – “99999”, number of triggers detected since power on. 
Pressing "Clear" resets counter to “00000”. Used for installation verification 
and troubleshooting. 

%B  0 Clear message indicates that the data buffers are cleared. 
%H dddd 4 Aircraft heading x10 (0000 - 3599). Heading outside valid range indicates 

heading not available or "flagged" (e.g., 9999). When configured for Stepper 
heading, this message contains relative heading angle. 

%D 14 lines  
(24 columns 
+CR) 

350 System Data Screen text requested by the host. The System data is sent in 
addition to the standard communications block prefixed by its own STX and 
followed by its own ETX. The System data screens may contain software 
versions, environmental parameters or the fault log. One of the System Data 
Screens is transmitted in response to a System Data Screen request. 

%L emmttbbb variable BFG Logo - generally requested only once during the power up sequence 
for display. The logo is a bitmap image of the BFG logo. e=Encoding type 
character (always “1”), mm=Msg number, tt=Total messages, bbb=Number 
of bytes of logo data in message, *=bbb bytes of logo.  

 
A message is sent from the sensor once every two seconds. Each message includes at least 
the sensor orientation and status. If strikes are detected, they are shown between the 
orientation data and the status data. Up to 40 strikes may be included in a single two-second 
message. If errors are detected, they will be included in the message as well.  
 
Below is a sample of the sensor output data stream that includes a description of the data 
immediately following the data. 
 

%VB1.03  (Software Version, sent at least twice per minute) 
%IPAG@  (Status = OK, Weather Mode) 
------------------------ 2 seconds ---------------------------- 
%H0000 (Sensor Orientation 0 - North) 
%IPAG@ (Status = OK, Weather Mode) 
------------------------ 2 seconds ---------------------------- 
%H0000 (Sensor Orientation 0 - North) 
%S026276026 (Lightning Strike = 26NM, 276 degrees)  
%S026278026 (Lightning Strike = 26NM, 278 degrees) 
%S027277027 (Lightning Strike = 27NM, 277 degrees) 
%S025279025  (Lightning Strike = 25NM, 279 degrees) 
%S027279027 (Lightning Strike = 27NM, 279 degrees) 
%S201279031 (Invalid Lightning Strike = 31NM, 279 degrees; “201” indicates an invalid strike) 
%IPAG@ (Status = OK, Weather Mode) 
------------------------ 2 seconds ---------------------------- 
%E16  (Error 16 – Antenna Fault) 
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Error Messages and Troubleshooting 
The Model 6502 continuously runs a series of self-tests to check sensor operation and returns 
error messages when a fault is detected. Any detected errors are identified by "E" and a two-
digit number ("E00" during normal operation) in the sensor’s raw data output. Table 2 lists 
all the possible error codes, along with the probable cause of the fault and possible corrective 
action. In many cases, a persistent error will require returning the sensor to All Weather Inc. 
for service.  

 
Table 2.  Model 6502 error codes 

ERROR PROBABLE CAUSE CORRECTIVE ACTION 
ERROR 01. Processor Fault. Main processor Continued operation is not possible. 

 Contact Field Service. 

ERROR 05. Processor Fault. Main processor memory Continued operation is not possible. 
 Contact Field Service. 

ERROR 06. Processor Fault. Main processor memory Continued operation is not possible. 
 Contact Field Service. 

ERROR 07. Processor Fault. Main processor memory Continued operation is not possible. 
 Contact Field Service. 

ERROR 08. Processor Fault. Main processor memory Continued operation is not possible. 
 Contact Field Service. 

ERROR 09. Processor Fault. DSP processor memory Continued operation is not possible. 
 Contact Field Service. 

ERROR 10. Processor Fault. DSP processor memory Continued operation is not possible. 
 Contact Field Service. 

ERROR 11. Processor Fault. DSP processor memory Continued operation is not possible. 
 Contact Field Service. 

ERROR 12. Processor Fault. DSP processor memory Continued operation is not possible. 
 Contact Field Service. 

ERROR 14. Processor Fault. DSP processor Continued operation is not possible. 
 Contact Field Service. 

ERROR 15. Processor Fault. DSP processor Continued operation is not possible. 
 Contact Field Service. 

ERROR 16. Antenna Fault. Antenna or antenna wiring Weather mapping is inhibited.   
a. Check antenna wiring for opens and shorts.  
b. Contact Field Service. 

ERROR 17. Processor Fault. No test strikes, antenna in 
noisy location, or faulty 
antenna  
 

Weather mapping is inhibited.  
a. Check antenna wiring for opens and shorts. 
b. Fault will clear automatically if interference 
 subsides.   
c. Contact Field Service. 
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Table 2.  Model 6502 error codes 

ERROR PROBABLE CAUSE CORRECTIVE ACTION 
ERROR 18. Processor Fault. Invalid test strikes, antenna in 

noisy location, or faulty antenna 
Weather mapping is inhibited.  

a. Check antenna wiring for opens and shorts. 
b. Fault will clear automatically if interference 
 subsides.   
c. Contact Field Service. 

ERROR 19. Processor Fault. Main Processor or Antenna in 
noisy location 

Weather mapping is inhibited.  
a. Fault will clear automatically if interference 
 subsides.   
b. Contact Field Service. 

ERROR 20. Configuration 
Changed. 

Antenna location (top/bottom, 
determined by processor 
wiring) changed since system 
was last powered up. 

This may occur the first time the system is powered 
on in a new installation. Power the sensor off and 
back on again. If the error persists, contact Field 
Service. 

ERROR 21. Processor Fault. Main processor Continued operation is not possible. 
 Contact Field Service. 

ERROR 22. Invalid XYZ Input. 
 
 

n/a n/a 

ERROR 23. Invalid Heading Ref. 
 
 

n/a n/a 

ERROR 24. MIC KEY STUCK. Mic key (inhibit line) has been 
asserted for at least 60 
seconds 

Weather mapping is inhibited.  
a. Contact Field Service. 

ERROR 25 - 34. Processor 
Fault. 

Main processor Continued operation is not possible. 
 Contact Field Service. 

ERROR 35. Processor Fault. Main or DSP processor Continued operation is not possible. 
 Contact Field Service. 

ERROR 36. Processor Fault. Main or DSP processor Continued operation is not possible. 
 Contact Field Service. 

ERROR 40. Processor Fault. Main processor Continued operation is not possible. 
 Contact Field Service. 

ERROR 41. Processor Fault. Main or DSP processor Continued operation is not possible. 
 Contact Field Service. 

ERROR 42. Processor Fault. Main processor Continued operation is not possible. 
 Contact Field Service. 

ERROR 43. Invalid request. n/a Message error will clear once processed   
a. Excessive noise on communication lines, 
 check wiring.  
b. If error occurs frequently, contact Field 
 Service 
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Table 2.  Model 6502 error codes 

ERROR PROBABLE CAUSE CORRECTIVE ACTION 
ERROR 44 - 49. Serial 
Communication. 

n/a Message error will clear once processed  
a. Improper baud rate.   
b.  Excessive noise on communication lines, 
 check wiring.  
c.  If error occurs frequently, contact Field 
 Service. 

ERROR 50. Illegal Serial 
Heading Value. 

n/a Message error will clear once processed   
a. Excessive noise on communication lines, 
 check wiring.  
b. If error occurs frequently, contact Field 
 Service. 

ERROR 51. Invalid Message. n/a Message error will clear once processed   
a. Excessive noise on communication lines, 
 check wiring.  
b. If error occurs frequently, contact Field 
 Service. 

ERROR 52. Invalid Antenna 
Change Request. 

n/a Message error will clear once processed  
a. A request was received to change the 
 antenna mount to a location that does not 
 match the configuration jumpers. Request is 
 ignored.   
b. If error occurs frequently, contact Field 
 Service. 

ERROR 53 - 54. 
Communications Buffer 
Overload. 

n/a Message error will clear once processed   
a. Excessive noise on communication lines, 
 check wiring.   
b. If error occurs frequently, contact Field 
 Service. 

   
Table 3 lists some common problems that may arise and the corrective action to take. 

Table 3.  Troubleshooting 

PROBLEM CORRECTIVE ACTION 
Computer will not run Check power cable to computer; make sure power switch is ON. 

Computer runs, but no display Check cables to display; make sure display power switch is ON 

Display software does not start 
automatically 

Double-click AWI Lightning Display icon on desktop OR restart computer 

Application runs, but no lightning data Check all connections 
Check radio status (refer to  radio manual) 
Check power to the lightning sensor 
At lightning sensor: 
 Check lightning sensor status LEDs;  

check radio lights inside lightning sensor cabinet 
check AC power board, replace if faulty 

If the problem persists, contact your local representative or AWI Customer Service. 
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Processor LEDs 
The processor (housed within the enclosure) is equipped with a series of LEDs on its front 
panel (see Figure 22) that can be used to monitor certain basic functions. Table 4 explains 
how to interpret the LEDs. 

 

DSP

Main

Serial

 
Figure 22.  Processor front panel LEDs 

 
Table 4.  Processor LED functions 

COMMUNICATION LED NORMAL OPERATION FAILED OPERATION 

DSP 1 ON OFF 

6 Toggles ON/OFF  
when strike detected 

Does not toggle ON/OFF  
when strike detected 

7 OFF ON MAIN 

8 Toggles ON/OFF  
once per second 

Stays ON or OFF  
(does not toggle) 

T Reserved for future use Reserved for future use 

RX Reserved for future use Reserved for future use 

TX ON 
(pulses when TX occurs) * 

Stays OFF or ON 
(does not pulse) 

SERIAL 

RX ON 
(pulses when RX occurs) * 

Stays OFF or ON 
(does not pulse) 

* Serial communication occurs every 2 seconds, causing LEDs to pulse rapidly. Due to transmission speed, LEDs may 
appear not to change conditions during TX/RX operation. 
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Maintenance 
Periodic Maintenance 
 
Equipment Required 
Equipment required for periodic maintenance of the Model 6502 consists of: 

• RTV 162 (as necessary) 
Monthly Maintenance 
No monthly maintenance is required with this sensor. 
Triannual Maintenance 
Perform the following maintenance tasks three times per year: 

• Check the antenna for dents, cracks, or punctures. 
• Remove all dirt and grease from surface areas using a soft cloth moistened with  mild 

soap and water. 
• Check the sealant around the antenna base and mounting bolts, and reapply as 

necessary (use RTV 162). 
• Check all hardware for corrosion and ensure that all bolts and connectors are tight. 
• Ensure that the cable connections are sound between the sensor and the display 

station. 
Annual Maintenance 
Annual maintenance consists of performing the quarterly maintenance tasks. 

 
Specifications 
 
Measuring Range: 0-200 nautical miles 
Internal Voltage: 11-32 volts dc 
Current: 0.82 A (maximum) @ 12 volts dc 
  0.38 A (maximum) @ 28 volts dc 
Operating Temperature: -60 to +70° C 
Relative Humidity: up to 100% 
Communication: RS-485, 4800 baud 
Mounting: 2½" pipe (2.875" O.D.) 
Weight: 40 lbs. (18 kg) 
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Warranty 
Unless specified otherwise, All Weather Inc. (the Company) warrants its products to be free 
from defects in material and workmanship under normal use and service for one year from 
date of shipment, subject to the following conditions: 

(a) The obligation of the Company under this warranty is limited to repairing or replacing 
items or parts which have been returned to the Company and which upon examination 
are disclosed, to the Company’s satisfaction, to have been defective in material or 
workmanship at time of manufacture. 

(b) The claimant shall pay the cost of shipping any part or instrument to the Company. If the 
Company determines the part to be defective in material or workmanship, the Company 
shall prepay the cost of shipping the repaired instrument to the claimant. Under no 
circumstances will the Company reimburse claimant for cost incurred in removing 
and/or reinstalling replacement parts. 

(c) This warranty shall not apply to any Company products which have been subjected to 
misuse, negligence or accident. 

(d) This warranty and the Company’s obligation thereunder is in lieu of all other warranties, 
express or implied, including warranties of merchantability and fitness for a particular 
purpose, consequential damages and all other obligations or liabilities. 

 
No other person or organization is authorized to give any other warranty or to assume 

any additional obligation on the Company’s behalf, unless made in writing and signed by an 
authorized officer of the Company. 
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